Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat | DONATE
Deploying a XCode project — Gideros Forum

Deploying a XCode project

mcapppmcappp Member
edited December 2020 in General questions
Hello,

After generate the XCode project, I've sent to distribute to iStore. I've got a email from Apple:

ITMS-90809: Deprecated API Usage - New apps that use UIWebView are no longer accepted. Instead, use WKWebView for improved security and reliability. Learn more (https://developer.apple.com/documentation/uikit/uiwebview).

So, i don't know exactly what libraries on my project are going with this error. My project has the following libraries classes attached:

tntanimator.lua
ace.slide.lua
TextWarp.lua
Button.lua
dataSaver.lua
easing.lua
gtween.lua
json.lua
lib.lua
scenemanager.lua
Admob

I'm using Gideros 2011.1

Is there any way how to fix this warning?


Comments

  • hgy29hgy29 Maintainer
    Looks like it is an AdMob issue (again!). By the look of the release notes here (https://developers.google.com/admob/ios/rel-notes) it has been fixed in AdMob 7.55, but we are using 7.21. Time to upgrade I suppose, but we'll need someone to validate.

    Likes: antix

    +1 -1 (+1 / -0 )Share on Facebook
  • Ok, it seems good news. I'm just uploading the app on iStore. If there is a way how to upgrade Admob on my Xcode project or test a new Gideros building, for sure I will go for it.
  • the tricky part with new admob is that it collects users data whereas the admob version gideros uses does not. if we upgrade admob we will need to implement EU stuff, have a website with policy, ask the users within our app, add a link to our privacy thing, ... I am quite happy with admob we have now.
    my growING GIDEROS github repositories: https://github.com/mokalux?tab=repositories
  • hgy29hgy29 Maintainer
    @MoKaLux, maybe we can upgrade for iOS only. Anyhow this upgrade will probably be a big task even if we only deal with the ios part.

    Likes: MoKaLux

    +1 -1 (+1 / -0 )Share on Facebook
  • MoKaLuxMoKaLux Member
    edited December 2020
    unfortunately yes, that's a big task. i don't have any apple. Now is it high priority, does the app make profits from admob? can it be done in xcode instead?
    my growING GIDEROS github repositories: https://github.com/mokalux?tab=repositories
  • hgy29hgy29 Maintainer
    It turned out to be not that difficult to update. All it needs is to have installed/setup cocoapods, and use the attached file (inside the zip) in replacement of the one bundled with current gideros (in the All Plugins/ads folder).
    zip
    zip
    ads.zip
    4K

    Likes: MoKaLux

    +1 -1 (+1 / -0 )Share on Facebook
  • After change the file on Gideros the exporting results fine but with following warning:

    [33mWARNING: CocoaPods requires your terminal to be using UTF-8 encoding.
    Consider adding the following to ~/.profile:

    export LANG=en_US.UTF-8
    [0m
    /usr/local/Cellar/cocoapods/1.9.1/libexec/gems/cocoapods-1.9.1/lib/cocoapods/command.rb:118:in `git_version': Failed to extract git version from `git --version` ("xcrun: error: active developer path (\"/Applications/Xcode.app/Contents/Developer\") does not exist\nUse `sudo xcode-select --switch path/to/Xcode.app` to specify the Xcode that you wish to use for command line developer tools, or use `xcode-select --install` to install the standalone command line developer tools.\nSee `man xcode-select` for more details.\n") (RuntimeError)
    from /usr/local/Cellar/cocoapods/1.9.1/libexec/gems/cocoapods-1.9.1/lib/cocoapods/command.rb:130:in `verify_minimum_git_version!'
    from /usr/local/Cellar/cocoapods/1.9.1/libexec/gems/cocoapods-1.9.1/lib/cocoapods/command.rb:49:in `run'
    from /usr/local/Cellar/cocoapods/1.9.1/libexec/gems/cocoapods-1.9.1/bin/pod:55:in `'
    from /usr/local/Cellar/cocoapods/1.9.1/libexec/bin/pod:23:in `load'
    from /usr/local/Cellar/cocoapods/1.9.1/libexec/bin/pod:23:in `
    '


    On Xcode the project build ends with error:

    Module 'GoogleMobileAds' not found

  • hgy29hgy29 Maintainer
    Your cocoa pods install is incomplete, or rather you forgot to setup Xcode CLI. do what the warning says:
    Use `sudo xcode-select --switch path/to/Xcode.app` to specify the Xcode that you wish to use for command line developer tools, or use `xcode-select --install` to install the standalone command line developer tools.\nSee `man xcode-select` for more details.
  • anefioxanefiox Member
    Hi I can't download the zip file. Is it still available or is the update now bundled with the plugin?
  • hgy29hgy29 Maintainer
    It is in Gideros bundle now.
    +1 -1 (+2 / -0 )Share on Facebook
Sign In or Register to comment.