Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat | DONATE
Gideros Studio IDE unusable on macOS Mojave 10.14.3 pls help! — Gideros Forum

Gideros Studio IDE unusable on macOS Mojave 10.14.3 pls help!

I was excited to start learning Gideros but it won't work properly on my Mac mini 2018 i5 32GB running macOS Mojave 10.14.3. I have connected it to a standard 1080p monitor via an external GPUs with radeon rx580 8GB. The IDE looks very wrong, no matter what theme I use in some places I see no text (like where I set bundle id stuff for iOS/android. Typing code sometimes gets very sluggish and has even behaved as if I was pressing backspace a few times in a row. Running the player sometimes freezes up the computer forcing me to reboot. Has anyone else encountered these problems and know how to solve them? Please let me know.



  • TechBoxNorthTechBoxNorth Member
    edited March 2019
    Thanks I'll look into that but I doubt it will solve the graphical problems with the IDE :)

    edit: the forum thread that @hgy29 referred to did not apply in my case.
  • Hi @TechBoxNorth - Sorry you're having troubles. I'm on a Mac and using Mojave, and while the latest Gideros Studio is definitely a bit sluggish, I believe in my case it's cause by the retina screen. When I drag the Gideros Studio window to a lower resolution monitor, it feels more responsive.

    I haven't had any crashes any other problems though.

    I'm wondering whether is a graphics driver or something along those lines, that might be causing the issue.
  • Hello again! After some tinkering with theme settings and better understanding how the Gideros Player works I'm good to go, now I just have to start learning so if anyone knows where I can find learning materials that would be awesome! Thanks for the response :smile:
  • antixantix Member
    edited March 2019
    @Ninjadoodle Aren't all macs using the same hardware so don't have driver issues? I dunno.. I'm not rich enough to have an apple ;)

    Likes: Ninjadoodle

    +1 -1 (+1 / -0 )Share on Facebook
  • I'm updating my Mac to Mojave so I can try see what you mean...
    Coder, video game industry veteran (since the '80s, ❤'s assembler), arrested - never convicted hacker (in the '90s), dad of five, he/him (if that even matters!).
  • Just for the sake of investigating I have tried with my external gpu set as boosting back to the internal gpu of the Mac mini and then with no egpu and it made no difference so now I'm back to running the graphics from the mini via the egpu to the monitor. Don't know if this info helps but like I said I have found a combination of theme settings that at least makes most of the text etc in the IDE visible so I can use it.

    Likes: Ninjadoodle

    +1 -1 (+1 / -0 )Share on Facebook
  • I installed the Mojave on my Mac, latest version. I have no speed issues at all.
    Coder, video game industry veteran (since the '80s, ❤'s assembler), arrested - never convicted hacker (in the '90s), dad of five, he/him (if that even matters!).
  • @antix - hey dude, honestly I'm not sure lol. I just know that these days anything can throw things out of whack :)

    @TechBoxNorth - Did you manage to get things working, or is it still acting funny? I wish I could help, but apart from the Gideros Editor being a little bit laggy on a Retina screen, everything works fine for me.

    Let me know if I can test anything etc :)
  • @Ninjadoodle I think the lag was because I didn't completely understand how the Gideros Player works but now I know how to use it properly and it works fine.

    @antix Not all Macs have the same gpu so for sure there can be some differences but after some tweaking with the themes that is now also solved.

    So far I have the Gideros remote player working on android but I can't get it to work on iOS. Same goes for exporting, works fine on android but won't work on iOS because of some errors in Xcode I don't understand:

    CAMetalLayer *metalLayer; > "unknown type name 'CAMetalLayer'
    id metalDrawable; > "No type or protocol named 'CAMetalDrawable"

    Can anyone help with this?
  • hgy29hgy29 Maintainer
    seems like your iOS SDK is too old. Which version of XCode do you use ?
  • I have Xcode 10.1 installed from the App Store
  • and Gideros 2019.2 (downloading 2019.2.1 now but at very slow downspeed )
  • hgy29hgy29 Maintainer
    Ah wait, it may do that if you try to compile/launch on simulator, because simulator doesn't support metal libs! select a real iPhone/iPad or a generic iOS device

    Likes: SinisterSoft

    +1 -1 (+1 / -0 )Share on Facebook
  • Oh, well the more you know :) I'll try it when the download is finished and installed
  • Well exporting to my iPhone worked.. once! Now when I try again I get errors about application identifiers, keychain access and provisioning files.
    What is happening? I didn't change anything.
    353 x 251 - 38K
  • hgy29hgy29 Maintainer
    Apple signing stufff... if I were you I would simply delete the exported project from disk and re export it, hoping that it was just some Xcode glitch...
  • Already tried that 3 or 4 times, also tried rebooting and finally making an entire new project and exporting it and I still get the same errors with the new project
  • Made a new iOS project in GameMaker Studio 2 and exported it and everything works fine but I'd rather use Gideros!
  • @TechBoxNorth - Like you I'm having some trouble getting the iOS player to work. The projects export fine for me however, so I really don't know what it could be :(
  • I have uninstalled Gideros and Xcode and rebooted, now I'm in the process of re-installing it all again. I'll post again to tell how it goes
  • Nope still same problem and I'm out of ideas. If anyone can help please let me know!
  • hgy29hgy29 Maintainer
    Can you share your .gproj file ? Maybe there is something wrong in the project settings, like bad app id or version or whatever ?
  • I'm in the final stages of clean install of macOS, just a few things left to do. I have also performed a factory reset on my iPhone 8+. I'll come back later to tell how it goes
  • Well the signing works now but I can't run a project on my iPhone, I get an error that says that my phone has denied the launch request, haven't seen that before.. *sigh* will this never work?
    427 x 140 - 73K
  • hgy29hgy29 Maintainer
    it happened to me once or two, maybe not that exact message though. Eventually the phone prompts you for a code but you're busy on the Mac and the phone enters sleep mode before you had a chance to see it...
  • I have set it to not go into sleep mode, it never asks for a code
  • Weird thing is that after I have tried to launch the game on my phone from Xcode and get the denied msg, if I reboot the phone the game can be started like any other installed game.
Sign In or Register to comment.