Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat | DONATE
The UWP .pfx certificate file - can I use it elsewhere? — Gideros Forum

The UWP .pfx certificate file - can I use it elsewhere?

saeyssaeys Member
edited February 2023 in General questions
I have a question about the UWP export and the certificate created.

I'm trying to make a MSIX package out of an install EXE made with InstallForge and a Windows Desktop export from Gideros.

But I need a signed certificate for the MSIX Packaging Tool. I take it I cannot use the .pfx certificate file that was generated during UWP export?

I'm not too versed when it comes to the wonderful world of certificates, but I hope this is the last obstacle.

(The plan is to publish my app at Microsoft Store. I have abandoned the UWP export solution via Visual Studio because of tons of errors when previewing/packaging/running through Visual Studio. On the other hand, running the Desktop Export works like a charm, the workaround seems reasonable.)


  • hgy29hgy29 Maintainer
    You need to generate your own .pfx that match your identity. The default one won't fit I am afraid. You can do it with visual studio.
    I'd stick to UWP if I were you, because desktop exports have licensing issues (it is GPL basically, meaning that you must disclose your source code too, unless you buy a QT license).

    Likes: saeys

    +1 -1 (+1 / -0 )Share on Facebook
  • Thank you for your reply! Well I have been - for days - struggling with Visual Studio getting an error-free build, preview or packaging process. I've learned to ignore the tons of warnings during build but I allways get to road's end with an error, often (but not only):

    - LINK1104 errors, like "cannot open file 'x64\Release\giderosgame.Windows.iobj' or
    - ILC1104 errors - access to paths denied, to \giderosgame\giderosgame.Windows\x64\Release\ilc\intermediate (very common)

    I've tried many things (for many many hours) to get around these (like running as admin, disabling virus protection, deleting everything and starting over, checking configurations and settings) and browsing for solutions, but on my developer level it seems impossible to get these errors sorted out. I get some of these errors even when I try to package Bird Animation, as a test.

    Most of the times I cannot work out if the errors originates from my code, or the UWP export, Visual Studio itself or something else. EXCEPT for a few points in time where the microphone plugin seemed to have caused the error. (Plugins I'm using are JSON, LiquidFun, Microphone and Require - maybe Require is obsolete?)

    It's only natural that I'm looking for alternative ways to get a package that is submittable to Microsoft Store. Like converting an error-free, fully functional desktop export into a MSIX file. Even the microphone feature works that way with no issues. BUT if the desktop version have a GPL license (basically) I cannot monetize from it like I do from my iOS and Android versions. So if I really want to get it out on Microsoft Store (there is a demand for it) I need to stick to UWP Visual Studio. Argh. What to do...
  • hgy29hgy29 Maintainer
    Accepted Answer
    On Gideros side, I know that JSON, LiquidFun and Require (which isn't a real plugin) do work well on UWP, but I am not sure for microphone.
    The errors you get with VS are very strange, as if something on your computer was interferring. I would have thought about the antivirus but you tried that already. Are you using the latest VS2022 ?

    Likes: saeys

    +1 -1 (+1 / -0 )Share on Facebook
  • saeyssaeys Member
    edited February 2023
    Okay, thanks for the clues. It seems quite obvious that the Microphone plugin doesn't work on UWP. I removed the Microphone plugin & code before UWP export - after that I can run and package the app in Visual Studio with no issues.* (Still tons of warnings during build but I've learned to ignore those :smile: )

    I guess those linker errors etc can be derived circuitously from the plugin not working with VS. Quite misleading error messages though... And since the microphone works well with Desktop export I was too far from suspecting the Microphone plugin.

    I have absolutely no competence in modifying the plugin to work with UWP, so I guess I have to keep the mic feature disabled (not essential in my app). Or get it out on Amazon Appstore instead. B)

    * It seems movieclips are played faster when run from an UWP export. They are out of sync with sound files in my app (I have a character who is animated with lipsync). In any other platform sound and movieclip seem to sync fine together.

    Likes: MoKaLux

    +1 -1 (+1 / -0 )Share on Facebook
  • hgy29hgy29 Maintainer
    I think microphone plugin broke when I replace xaudio backend with openal. I'll try to fix it.

    Thanks for the report about MovieClip, I'll investigate that too. Do you use it with real times or with frame counts ?

    Likes: saeys

    +1 -1 (+1 / -0 )Share on Facebook
  • hgy29 said:

    Do you use it with real times or with frame counts ?

    Uhm, actually I'm not sure (can't find any docs on that). Frame counts I think, 60 frames per second (seems to be more on UWP play).
  • hgy29hgy29 Maintainer
    I've had a look at microphone plugin for UWP, and it isn't broken... it just doesn't exist at all. I'll try to write one anyway.

    Likes: saeys

    +1 -1 (+1 / -0 )Share on Facebook
  • saeyssaeys Member
    Note to self (and others), and a bit off-topic:
    Beware of spaces in gideros export path names when building projects in Visual Studio. (◔_◔)
Sign In or Register to comment.